WHMCompleteSolution (WHMCS) 5.0 knowledgebase.php search Parameter XSS

Source: http://www.securityfocus.com/bid/53740/info

WHMCS is prone to a cross-site scripting vulnerability

and multiple HTML-parameter-pollution

vulnerabilities because it fails to properly

sanitize user-supplied input.

Attacker-supplied HTML and script code would run in the context of the affected browser,

potentially allowing the attacker to steal cookie-based authentication credentials,

control how the page is rendered to the user, and override

existing hard-coded

HTTP parameters which compromises the application.

WHMCS 5.0 is vulnerable; other versions may also be affected.

http://www.example.com/knowledgebase.php?action = [XSS]